Adobe InDesign/Time Saving Tips for InDesign

From WSU Technology Knowledge Base
Jump to: navigation, search
Adobe1.jpg


Many students on campus spend hours working in the Adobe design programs to create projects for classes. It takes years of experience, or a great deal of exposure, to figure out all the ins and outs of a piece of software. For that reason there are a few basic Time Saving Tips for InDesign.




Customize your workspace in design applications

It is important to have your necessary tools and panels open for you to use right away to speed up your workflow. These tools and panels needed change based upon the type of project you are working on. Adobe design programs have multiple standard default workspace settings that you can use. Experiment with different set-ups to find the best for your project. You can also customize your workspace to further fit your workflow needs. If you have customized your space, it is best to save a workspace after you have worked on the document for a while, rather than at the beginning so you have a good feel of what you need.

  • While working in a document: Open, close, and reorganize panels, window layout and interface to optimal conditions
  • In the menu bar, go to: Window > Workspace > New Workspace
  • Give the workspace a name (ex. Brochure Layout), and check the boxes to save the panels open and their locations
  • To use the layout in the future, Go to: Window > Workspace > title of your workspace

Customize your preferences in InDesign

InDesign, among the other Adobe design programs, give you the ability to set preferences. Here you can set general display settings, file saving settings, curser settings, along with other things. For an optimal design experience, you should customize these preferences in each of your design programs to best suit your needs.

To edit your preferences in InDesign: (Mac) InDesign > Preferences > General (Windows) Edit > Preferneces > General Preferences

Combine common graphics from past projects into one document for easy use in the future

If you are working on a campaign where there is more than one promotional piece for one project, you most likely will be using the same icons, logos, symbols, images, etc. through out your pieces. Combine all of these shared elements into one Illustrator or Photoshop document for future use. This will reduce the time it takes you to search through past design documents for an icon or symbol you have previously created. Note: Illustrator is the preferred program for vector art (usually logos and symbols).

Learn and practice using keyboard shortcuts, then create your own

A keyboard shortcut exists for most of the common commands and if there is not one, you can create your own. The time saving ability of keyboard shortcuts is priceless. To create your own select Edit > Keyboard Shortcuts (Windows) or InDesign > Keyboard Shortcuts (Mac OS). You can create different sets of shortcuts for different tasks
if desired. Browse to the command that you would like to edit and enter a new shortcut combination.

Note: To enter the key combination, press the keys on the keyboard. You do not need to spell out the key names, such as Control, Option, and so on.

For a list of InDesign keyboard shortcuts that are already defined click here.